
 

www.enisa.europa.eu                    European Union Agency For Network And Information Security 

Advanced artefact analysis  
Advanced dynamic analysis 

 

TOOLSET, DOCUMENT FOR STUDENTS 

 

 

 

 

OCTOBER 2015 

http://www.enisa.europa.eu/


Advanced artefact analysis 
    October 2015 

 
 
 
 

02 

About ENISA 

The European Union Agency for Network and Information Security (ENISA) is a centre of network and 
information security expertise for the EU, its member states, the private sector and Europe’s citizens. 
ENISA works with these groups to develop advice and recommendations on good practice in information 
security. It assists EU member states in implementing relevant EU legislation and works to improve the 
resilience of Europe’s critical information infrastructure and networks. ENISA seeks to enhance existing 
expertise in EU member states by supporting the development of cross-border communities committed to 
improving network and information security throughout the EU. More information about ENISA and its 
work can be found at www.enisa.europa.eu. 

Authors 
This document was created by Yonas Leguesse, Christos Sidiropoulos, Kaarel Jõgi and Lauri Palkmets in 
consultation with ComCERT1 (Poland), S-CURE2 (The Netherlands) and DFN-CERT Services (Germany). 

Contact 
For contacting the authors please use cert-relations@enisa.europa.eu 
For media enquiries about this paper, please use press@enisa.europa.eu. 
 

Acknowledgements 
ENISA wants to thank all institutions and persons who contributed to this document. A special ‘Thank You’ 
goes to Filip Vlašić, and Darko Perhoc. 

 

 

                                                           

1 Dawid Osojca, Paweł Weżgowiec and Tomasz Chlebowski 
2 Don Stikvoort and Michael Potter  

Legal notice 
Notice must be taken that this publication represents the views and interpretations of the authors and 
editors, unless stated otherwise. This publication should not be construed to be a legal action of ENISA or 
the ENISA bodies unless adopted pursuant to the Regulation (EU) No 526/2013. This publication does not 
necessarily represent state-of the-art and ENISA may update it from time to time. 
 
Third-party sources are quoted as appropriate. ENISA is not responsible for the content of the external 
sources including external websites referenced in this publication. 
 
This publication is intended for information purposes only. It must be accessible free of charge. Neither 
ENISA nor any person acting on its behalf is responsible for the use that might be made of the 
information contained in this publication. 
 
Copyright Notice 
© European Union Agency for Network and Information Security (ENISA), 2015 
Reproduction is authorised provided the source is acknowledged. 

https://www.enisa.europa.eu/
mailto:cert-relations@enisa.europa.eu
mailto:press@enisa.europa.eu.


Advanced artefact analysis 
    October 2015 

 
 
 
 

03 

Table of Contents 

1. Training introduction 5 

2. Introduction to OllyDbg 6 

 OllyDbg interface 6 

 Basic debugging and code navigation 14 

 Breakpoints 20 

 Execution flow manipulation 26 

 Plugins 28 

 Shortcuts 29 

3. Unpacking artifacts 31 

 Unpacking UPX packed sample 31 

 Unpacking UPX with ESP trick 40 

 Unpacking Dyre sample 44 

4. Anti-debugging techniques 54 

 Anti-debugging and anti-analysis techniques 54 

 Dyre - basic patching with OllyDbg 55 

5. Process creation and injection 59 

 Following child processes of Tinba loader 59 

5.1.1 First stage 59 
5.1.2 Second stage 68 

6. Introduction to scripting 74 

 Decoding hidden strings in Tinba 74 

 

  



Advanced artefact analysis 
    October 2015 

 
 
 
 

04 

Main Objective 

The aim of this training is to present methods and techniques of dynamic 

artefact analysis with the use of OllyDbg3 debugger package. 

Trainees will be following a code execution and unpack artefacts using 

the most efficient methods. In addition they will be tracing a malicious 

code execution. During the process trainees will learn how to counter the 

anti-analysis techniques implemented by malware authors.  

In the second part the trainees will study various code injection 

techniques and how to debug hollowed processes. At the end of the 

training they will be presented how to automate the debugging process.  

The training is performed using the Microsoft Windows operating system. 

Targeted Audience 

CSIRT staff involved with the technical analysis of incidents, especially 

those dealing with the sample examination and malware analysis. Prior 

knowledge of assembly language and operating systems internals is 

highly recommended. 

Total Duration 8-10 hours 

 

                                                           

3 OllyDbg http://www.ollydbg.de/ (last accessed 11.09.2015) 

http://www.ollydbg.de/
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1. Training introduction 

In this training you will learn practical elements of advanced dynamic analysis and debugging of malicious code. 

Except the introductory part, the samples used in this training are live malware samples. Consequently all analyses 
should be done in dedicated and isolated environments. After each analysis a clean virtual machine snapshot 
should be restored if not instructed otherwise. An Internet connection is not needed to complete this training. 
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2. Introduction to OllyDbg 

 OllyDbg interface 
First open OllyDbg debugger. Make sure to run it as Administrator. 

 

If you are using a Windows virtual machine prepared the same way as in the Building artefact handling and 
analysis environment4 training then you can also access OllyDbg using the context menu. 

 

Now you should see the OllyDbg interface. 

 

                                                           

4Building artefact handling and analysis environmenthttps://www.enisa.europa.eu/activities/cert/training/training-
resources/technical-operational#building (last accessed 11.09.2015) 

https://www.enisa.europa.eu/activities/cert/training/training-resources/technical-operational#building
https://www.enisa.europa.eu/activities/cert/training/training-resources/technical-operational#building
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There are two ways to start a debugging process. Firstly, you can attach to the already running process. To do this, 
choose File->Attach and then choose the process of your interest. After attaching to the running process, OllyDbg 
should automatically break at the ntdll.DbgBreakPoint function. 

 

The second way is to open an executable file using standard File->Open menu. This way OllyDbg will create a new 
child process with a debugged application (debuggee) and stop at the entry point of the executable (by default). 

For example, open the putty.exe binary in OllyDbg. After a while OllyDbg should finish its initial analysis. 
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The Central part of OllyDbg is the CPU window. 

Disassembly view (4) presents a listing with the disassembled code.

 

Registers view (5) presents the current state of CPU registers (for the currently selected thread). 
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Information panel (6) is used to present additional information about the instruction selected in disassembly view 
(e.g. operation result, registers values). 

 

Memory dump (7) presents a dump of the chosen memory region. 

 

Besides the hexadecimal, you can choose other data representation formats by right-clicking on the memory dump 
panel and choosing required data representation from the context menu. 

 

Take some time to check other data representations. At the end, restore the default format: Hex->Hex/ASCII (16 
bytes). 

Finally, stack panel (8) presents the stack state of the currently selected thread. 
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Besides the CPU window, OllyDbg offers few other windows used for different purposes. All windows can be 
accessed with windows buttons on the toolbar or View menu. 

 

 

The more frequently used windows are: Executable modules, Memory map, Threads, Handles, Call stack, 
Breakpoints. 

The Executable modules window presents all executable modules loaded in the address space of the debugged 
process. Usually, this would be a module of the executed binary and modules of loaded DLL libraries. You can 
double-click on any of the modules to immediately jump to this module in the disassembly view. You can also 
right-click on any of the modules to access context menu with additional operations. 
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For example, right-click on msvcrt and choose View names to be presented with a list of all names defined in the 
msvcrt library (imports and exports). 

 

Memory map window presents the memory structure with all allocated memory regions in the address space of 
the debugged process.  

 

For example sometimes it is useful to open an additional dump window with a dump of the given memory region. 
To do this double-click on the memory region or select it and choose Dump option from the context menu. 
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Another operation you might try is searching all memory regions for a particular string or byte pattern. Let’s say 
you know that somewhere in the memory the string ‘wrong passphrase’ is present, but you don’t know the exact 
address nor in which memory region is it located. 

To solve this problem, right-click anywhere in the memory map and choose Search (Ctrl+B) from the context menu. 
In the new window, type ‘wrong passphrase’ and click Ok. 

 

If the string is found OllyDbg will open a new Dump window with the position set on the string. 

 

To keep searching for other occurrences of this string in this memory region click on Dump window (to make it 
active) and keep pressing Ctrl+L.  
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To continue searching for the string in other memory regions go back to Memory map window (make it active) and 
keep pressing Ctrl+L. 

Threads window shows all threads of the current process. 

 

Handles window shows all windows opened by the process handles with an additional information regarding the 
handle type, value and name. This window may be useful if for example you see that some API call is referring to a 
certain handle and you don’t remember what this handle is. 

 

Finally call stack window shows all function calls made up to the current instruction in the current thread.  

 

One of the useful OllyDbg features is highlighting elements that have changed.  
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Open the Executable modules window. If there are any red coloured elements in the window, right-click it and 
choose Actualize. 

 

Next, right-click anywhere in the window and choose Insert module from the context menu (this operation is 
available only with Olly Advanced plugin). 

 

In the Open dialog, choose c:\Windows\System32\wininet.dll.  

Now all the newly loaded modules should be marked with red font in the Executable modules window.  

 

 Basic debugging and code navigation 
Start by loading the putty.exe sample as described in the previous exercise. 

The current state of the debugged process can be read in the upper left corner of the OllyDbg window. 

 

When the process is paused, the current position (the instruction pointer) is indicated by a black square in the 
disassembly view and by the value of EIP register. 
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Whenever you get lost, double-click on the EIP register value to be instantaneously moved to the current position 
in the code. Remember that if the program has multiple threads, the current position will likely be different for 
each thread. 

 

There are two modes of instruction stepping: 

 Step into (F7) – executes current instruction and moves program execution to the next instruction. If the 
current instruction is a function call then the debugger steps into the call and starts stepping over 
instructions of the called function. 

 Step over (F8) – behaves the same as Step into except if the current instruction is a function call, the 
debugger doesn’t step into this call. 

If you want to let the program run freely choose Run (F9). In the result, PuTTY will create its main window and 
present it to the user. If you want to pause the program execution then press F12 (Debug->Pause) while staying in 
OllyDbg. You can also restart the executable by pressing Ctrl+F2 (Debug->Restart). 

Other useful debug operations are: 

 Run to selection (F4) – causes OllyDbg to resume execution until the selected instruction 

 Execute till return (Ctrl+F9) – executes the program until return from current function 

 Execute till user code (Alt+F9) – executes program until user code 

Debugging actions can be also accessed through the toolbar at the top of OllyDbg. 
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If you want to quickly pre-view the execution flow of a program (find loops, check which jumps are taken, etc.) you 
might decide to use the instruction trace or instruction animation functions.  

 

Restart PuTTY sample (Debug->Reset) and then choose Debug -> Animate over (Ctrl+F8). Observe what happens in 
the disassembly window.  

Close PuTTY and reset the sample. Now choose Debug->Animate into. This time instead of stepping over, the 
animation will step into each function call (including API calls). You can open the Call stack (Alt+K) window to 
observe all called functions in the real time. 

 

Animate into function usually takes some time until the program finishes execution. To stop it, use Pause (F12) 
function. 

Next restart the sample again and choose Debug->Set condition. 
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Set the following two conditions. 

 

 

Now open Run trace window (View->Run trace) and then choose Debug->Trace over.  

 

This would also be indicated at the OllyDbg status bar in the bottom left corner. 

 

Now take a look at the Run trace window. 
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If you would like run trace to be logged to a file you should right-click on Run trace window and choose the Log to 
file option from the context menu (before executing Run trace function). 

First restart the PuTTY sample: 

 

Whenever you see some call or jump instruction you can follow it (without executing) by clicking on this 
instruction and pressing <Enter>. 

In this example follow a call to putty.004545A0. 

 

Another way of navigating through the code is using the Go to expression feature. 

Click on disassembly view and press Ctrl+G. 

 

Type eip to be moved to the current location in the code (pointed by EIP register). 

If the entered expression is invalid or the destination address doesn’t exist in the address space of the debugged 
process you will see a proper error message. 

 

Start clicking on registers values. If a register points to the existing address in the address space of the current 
program, there should be the following options: Follow in Disassembler and Follow in Dump. 
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If the register does not contain a valid address, these options won’t be available. Additionally if a register points to 
the location on the stack (like in case of ESP register) there will be an option Follow in Stack. 

You can do the same with values stored on stack. 
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 Breakpoints 
To set a software breakpoint, double-click in the second column next to the instruction or select an instruction and 
press F2.  

 

Now press F9 (run) and the program should stop execution on this instruction (before executing it). 

 

To remove a breakpoint, repeat the same steps as when setting it. 

You can view a list of all software breakpoints in the Breakpoints window. 

 

You can also use this window to remove or temporarily disable chosen breakpoints. 

Click on disassembly view and use Go to expression (Ctrl+G) to find the address of ShellExecuteA. 

 

Then set breakpoint on the first instruction of ShellExecuteA (the one to which you were moved). 

 

If the PuTTY process was paused, resume execution (F9). 

Next in the PuTTY window, click the About button and then the Visit Web Site button. 
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Now go back to OllyDbg. 

 

 

Take a look at the stack view to see arguments passed to ShellExecuteA. 

 

Open the call stack window (View->Call stack, Clt+K) to check from where ShellExecuteA function was called. 
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Go to OllyDbg and restart the PuTTY sample. 

 

Next, step over until the instruction at 0x454AF9. As you can see some dword value is being written to the memory 
at the address 0x47E140. 

 

Right-click on this instruction and from the context menu choose Follow in Dump->Memory address. 

 

 

Now Memory Dump view should be centred on the 0x47E140 address. Select the first 4 bytes (dword) and right-
click on them. From the context menu choose Breakpoint->Hardware, on access->Dword. 
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To view all currently set hardware breakpoints, choose Debug->Hardware breakpoints. 

 

After setting up a hardware breakpoint on 0x47E140, resume the program execution (F9). 

 

Scroll the disassembly view one line up to see the instruction accessing 0x47E140. 

 

You can now remove the hardware breakpoint (it is not automatically removed after the sample reload). 
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You can set memory breakpoints in a similar manner as hardware breakpoints by selecting some data in Memory 
Dump view and then choosing Breakpoint->Memory. 

 

The second way of creating a memory breakpoint is using Memory map window. 

Restart the PuTTY sample and open Memory map window. Then find PuTTY’s .resource section, right-click it and 
from the context menu, choose Set memory breakpoint on access. Now if some code tries to access any data in 
.resource section, the breakpoint would hit. 
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Next, resume the program (F9). The breakpoint should hit someplace in the system code. 

 

If you check Call stack window you will see that the breakpoint was hit after a call to CreateDialogParamA from 
which FindResourceExA was called. 

 

To remove a memory breakpoint, go to the Memory map window, right-click on the memory region on which the 
memory breakpoint was set and select Remove memory breakpoint. 
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 Execution flow manipulation 
First, restart the PuTTY sample and step over until the first jump instruction. 

 

You can force this jump not to be taken by changing then appropriate flag in the FLAGS register. 

 

JE (jump on equality) is taken whenever the zero flag (Z) is set. To change the zero flag, double-click on the value 
next to it. 

 

Now the jump won’t be made (grey arrow) 

 

You can also change a jump to never be made by overwriting the jump instruction with NOP instructions. To do 
this, just right-click on the jump instruction and choose Binary->Fill with NOPs. 
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In a similar way as modifying the FLAGS register you can also modify other registers. To do this, right-click on the 
register value and choose Modify. 

 

 

Values on the stack can be modified as well. 

 

This time however there are two options: Modify and Edit. 
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Besides modifying registers and data in the memory, it is also possible to change instructions that are executed. To 
achieve this just select the instruction you want to modify and press <space>. 

 

 Plugins 
After downloading a plugin, unpack it and copy the plugin’s .dll library to the OlyDbg’s plugin directory (e.g. 
c:\tools\Portable version\Olly_110\Plugins). The exact location of the plugins directory can be checked in the 
Options->Appearance->Directories menu. 
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After plugin installation, restart OllyDbg. If the plugin is working, it should be available through the plugins menu. 

 

Note that plugins created for OllyDbg v1.10 are not compatible with OllyDbg 2.xx and vice versa. 

There are many useful plugins for OllyDbg and it is mostly up to your preference which to use. Among the plugins 
used in this training are. 

 aadp4olly - tries to hide OllyDbg from most of the popular anti-debugger techniques. 

 Olly Advanced – fixes some bugs in OllyDbg v1.10 and introduces new functions enhancing OllyDbg 
capabilities. It also implements various anti-anti-debugging techniques. 

 ODbgScript – introduces scripting assembly-like language allowing to automate certain tasks. 

 OllyDumpEx – memory and PE dumping plugin. It allows to dump PE image from the memory to the 
file. Frequently used for dumping unpacked binaries. 

 Bookmarks – allows to insert bookmarks in the code to help quickly navigate to them later. 

 Shortcuts 
Shortcuts are essential parts of OllyDbg. Thanks to the shortcuts you can perform many operations much faster, 
saving valuable time. This section lists the most commonly used shortcuts in OllyDbg. 

Debugging: 

OPERATION SHORTCUT 

Run F9 

Pause F12 

Restart debugged app Ctrl+F2 

Close debugged app Alt+F2 

Step into F7 

Step over F8 

Execute till return Ctrl+F9 

Execute till user code Alt+F9 
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Pass exception to the program Shift+F7/F8/F9 

Animate into Ctrl+F7 

Animate over Ctrl+F8 

Trace into Ctrl+F11 

Trace over Ctrl+F12 

Windows and views: 

OPERATION SHORTCUT 

CPU window Alt+C 

Memory map Alt+M 

Executable modules Alt+E 

Call stack Alt+K 

Breakpoints Alt+B 

Other operations: 

OPERATION SHORTCUT 

Follow jump/call Enter 

Assembly instruction Space 

Edit memory Ctrl+E 

Add comment ; (semicolon) 

Add label : (colon) 

Insert bookmark X Alt+Shift+0..9 

Go to bookmark X Alt+0..9 
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3. Unpacking artifacts 

 Unpacking UPX packed sample 
PEiD5 is used to identify if the sample was packed and what packer was used. 

In this case, PEiD reveals that putty_upx.exe sample was packed with UPX as seen in the following screenshot. 

 

To confirm the output of PEiD and to identify packing more specifically, CFF Explorer6 is used. 

                                                           

5 PeiD http://www.aldeid.com/wiki/PEiD (last accessed 11.09.2015) 
6 CFF Explorer suite http://www.ntcore.com/exsuite.php (last accessed 11.09.2015) 

http://www.aldeid.com/wiki/PEiD
http://www.ntcore.com/exsuite.php
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Now, when you know that the sample was packed with UPX let’s move forward towards the manual unpacking. To 
do this, the sample is opened in OllyDbg. OllyDbg should report that the sample looks like compressed or packed 
code and ask whether to continue with automatic analysis of this code. Answer “No”. 

 

Execution of the executable should be paused at the entry point of putty_upx.exe (0x48CD50) which is located in 
the UPX1 section.  



Advanced artefact analysis 
    October 2015 

 
 
 
 

33 

 

In order to reach the beginning of an unpacking routine, step over the function (Shortcut key F8) five times until 
the MOV EBX,DWORD PTR DS:[ESI] instruction (at the address 0x48CD6A). 

 

Take a look at ESI (source) and EDI (destination) registries. ESI points to the beginning of the UPX1 section while 
EDI points to the beginning of UPX0 (refer to previously checked Virtual Addresses in CFF Explorer). 

To see packed code follow in the hex dump (Ctrl+G) ESI register. 

 

Then follow in the hex dump EDI register to see a clean memory where unpacked code will be stored. 
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Then press and hold for a few seconds the Step Over key (F8).  

 

Now scroll down over numerous jump instructions until you see three CALL instructions (at the addresses 
0x48CE8A, 0x48CEA8, 0x48CEB9). Set breakpoints at those instructions to inspect what functions are called there. 
Resume execution (F9). 

 

Put breakpoint at 0x48CEBF (outside IAT reconstruction loop) and press F9 a few times (5-10). 
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Follow EBX register in hex dump. 

 

Now remove all the breakpoints except the breakpoint outside the IAT reconstruction loop (0x48CEBF) and resume 
execution (F9) to let the IAT reconstruction finish.  

 

Right-click the hex dump and from the context menu choose LongAddress. 
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Next scroll down the assembly code until the characteristical JMP instruction at 0x48CEFC. Put a breakpoint at this 
instruction and resume the execution (F9). 

 

After reaching the breakpoint at the JMP instruction do a single step (F7/F8) to land at the OEP. In this case you 
can recognize the OEP by calls to functions such as GetVersionExA or GetModuleHandleA. Remember the address 
of the OEP (0x459FE0) because it will be needed later. 
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In the next step you will dump the unpacked process image to the executable file. To achieve this you will use the 
OllyDumpEx plugin which allows to dump a process image from the memory to the executable file in PE format. 

When dumping unpacked putty.exe code use the default OllyDumpEx settings. Save dumped process as dump.exe. 
Don’t close OllyDbg yet. 

 

Now if you would try to execute dump.exe you will see an Application Error. That’s because dump.exe still doesn’t 
have the IAT reconstructed. 
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To reconstruct IAT you will use the ImpREC7 tool. Run ImpREC (as Administrator) and from the scroll down menu at 
the top of the window choose the putty_upx.exe process. 

 

 

                                                           

7ImpREC http://www.woodmann.com/collaborative/tools/index.php/ImpREC (last accessed 10.10.2015) 

http://www.woodmann.com/collaborative/tools/index.php/ImpREC
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Next in the “IAT Infos needed” panel enter the RVA address of the OEP (OEP address minus Image Base address, in 
this case 0x459FE0-0x400000=0x59FE0) and click “IAT AutoSearch”. If the IAT is found you should see the 
appropriate message box. Otherwise you might need to try and manually enter RVA and Size of the IAT. 

 

Next click “Get Imports”. 
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Click “Show Invalid” to see if there are any invalid functions. In this case there shouldn’t be any. Click “Fix Dump” 
and select dump.exe file. If everything goes right you should see a message that dump_.exe was saved successfully 
(please note underscore in the name of  the file name, the originale file wasn’t overwritten). 

You can try to run dump_.exe to check if it runs. 

 Unpacking UPX with ESP trick 
Open putty_upx.exe in OllyDbg. 
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Step over PUSHAD instruction (Shortcut key F8). Notice how the stack view and ESP register changes, as seen on 
the following screenshot. 

 

 

Follow the ESP register in the hex dump and put a hardware breakpoint (on access) on the memory region pointed 
to by this register. 
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Next resume the execution (F9) and you should immediately land just before the jump to the OEP. 

 

Remove the hardware breakpoint (Debug -> Hardware breakpoints, Delete). 
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Now put a breakpoint on the JMP instruction (0x48CEFC), and resume the execution (F9) until you reach it. Step 
over the JMP instruction (F8) and you should land at the OEP. 
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 Unpacking Dyre sample 
In this exercise the unpacking of the Dyre8 malware will be presented. Dyre is a banking trojan and was packed 
using a more complex packer than UPX. Since it is a live malware sample, run it only in a controlled virtual 
environment and after the analysis restore a clean snapshot of the virtual machine. It is also advisable to forbid 
any network access while working on Dyre. 

Open the file called voiyhabs.exe in the OllyDbg. You should see the entry point. 

 

Put a breakpoint on ZwAllocateVirtualMemory (as described in the introduction to OllyDbg).   

 

Now open the Call stack window (View->Call Stack, Alt+K) and press the resume execution (F9) a few times until 
you see a call to HeapCreate with flags set to 0x40000.  

 

Remove the breakpoint from ZwAllocateVirtualMemory and show the calling location of HeapCreate in the 
voiyhabs module. 

 
                                                           

8Dyre: Emerging threat on financial fraud landscape 
http://www.symantec.com/content/en/us/enterprise/media/security_response/whitepapers/dyre-emerging-
threat.pdf (last accessed 19.10.2015) 

http://www.symantec.com/content/en/us/enterprise/media/security_response/whitepapers/dyre-emerging-threat.pdf
http://www.symantec.com/content/en/us/enterprise/media/security_response/whitepapers/dyre-emerging-threat.pdf
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Put a breakpoint on the instruction after the HeapCreate call and resume the execution (F9). Write down the 
address of the newly created heap (returned in EAX register, 0xDE0000 in this example, might be different). 

 

 

Remove the previously set breakpoint (0x40144D) and scroll down until you see a call to RegisterClassEx function 
(0x4018DE). Put a breakpoint on this function and resume the execution (F9). 

 

Next you will check the address of the window procedure in a registered window class. Hiding some code in a 
window procedure is a common technique used by a malware to hinder analysis and change the execution flow. If 
the window procedure points to an existing address it is good to put a breakpoint at this address. 

The window procedure address is passed in a third field of the WndClassEx structure (lpfnWndProc) preceded by 
two INT values. This means that this address is a third DWORD value in the WndClassEx structure. 

typedef struct tagWNDCLASSEX { 

  UINT      cbSize; 

  UINT      style; 

  WNDPROC   lpfnWndProc; 

  int       cbClsExtra; 

  int       cbWndExtra; 

  HINSTANCE hInstance; 

  HICON     hIcon; 

  HCURSOR   hCursor; 

  HBRUSH    hbrBackground; 

  LPCTSTR   lpszMenuName; 

  LPCTSTR   lpszClassName; 

  HICON     hIconSm; 

} WNDCLASSEX, *PWNDCLASSEX; 

Address of the WndClassEx structure is put as the first argument onto the stack. Follow it in the dump. 
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Now read the address of the Window procedure from the hex dump remembering that addresses are written in 
the little-endian notation. In this case the Window procedure address is 0x02100210. 

 

Next try to follow this address in the assembly window. If you land in the existing code section, put a breakpoint at 
this address. To go back to the current location you can follow the EIP register. 

Next scroll down until a call to EnumDisplayMonitors function. Put a breakpoint on this call and resume the 
execution (F9) or alternatively select this location and use Run to selection (F4). 

 

BOOL EnumDisplayMonitors( 

   _In_  HDC             hdc, 

   _In_  LPCRECT         lprcClip, 

   _In_  MONITORENUMPROC lpfnEnum, 

   _In_  LPARAM          dwData 

); 

Check the address of the enumeration procedure (lpfnEnum) on the stack (the third argument, in this example 
0xEDE688). 
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Put a breakpoint on the enumeration procedure (in the assembly window go to the address of the enumeration 
procedure – lpfnEnum and toggle a breakpoint on this address). Resume the execution (F9). 

 

The execution should break inside the enumeration procedure. Step over (F8) two times to follow the jump. 

 

Scroll down and put a breakpoint on the suspicious CALL EAX just before the function return (RETN). 

 

Resume the execution (F9). When you hit the breakpoint on CALL EAX step into (F7) the call. You should land in 
another unpacking stub function. 

 

Step over (F8) two times. 

 

Now scroll down until a group of three calls just before function return. Put a breakpoint on the first call and 
resume the execution (F9). 

 

After reaching the breakpoint step into the first function call (F7). You will see several PUSH instructions followed 
by a call instruction.  
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When you step over (F8) to this call instruction you will see this is a call to CreateThread function.  

 

HANDLE WINAPI CreateThread( 

  _In_opt_  LPSECURITY_ATTRIBUTES  lpThreadAttributes, 

  _In_      SIZE_T                 dwStackSize, 

  _In_      LPTHREAD_START_ROUTINE lpStartAddress, 

  _In_opt_  LPVOID                 lpParameter, 

  _In_      DWORD                  dwCreationFlags, 

  _Out_opt_ LPDWORD                lpThreadId 

); 

Now take a look at the stack. The thread routine is passed as the third argument. In this example it points to 
0xEE38AC. 

 

Put a breakpoint on the thread function (lpStartAddress) and resume the execution (F9). 
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When a breakpoint at the thread function is hit step over (F8) until a call to ECX. Step into the call (F7). 

 

You should land at the OEP with overwritten code which OllyDbg hasn’t analysed properly. 

 

Starting at the OEP address select a group of instructions. Next right-click on them and from the context menu 
choose ‘Analysis->During next analysis, treat selection as->Command’. 
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Now click on them once again and from the context menu choose ‘Analysis->Analyse code’. 
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Next you will dump the process image and reconstruct the IAT table. To dump the process use OllyDumpEx plugin 
(as described previously). 
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Now try to reconstruct the Import Address Table (RVA of the OEP: 0x3850) by using ImpRec. This time you might 
see some invalid imports after clicking Get Imports and Show Invalid. Right-click on each of them and from the 
context menu choose Cut thunks(s). After all invalid pointers are resolved, use Fix dump to fix the dumped 
executable. 
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4. Anti-debugging techniques 

 Anti-debugging and anti-analysis techniques 
One of the countermeasures for anti-debugging is to use special plugins for OllyDbg like aadp4olly9 and Olly 
Advanced10. 

When using those plugins you need to check which anti-anti-debugging techniques should be used. You can do this 
by accessing the plugin’s options dialog via Plugins menu.  

 

The screenshot below presents the anti-anti-debugging options of aadp4olly plugin. 

 

                                                           

9aadp4olly https://tuts4you.com/download.php?view.3021 (last accessed 11.09.2015) 
10Olly Advanced https://tuts4you.com/download.php?view.75 (last accessed 11.09.2015) 

https://tuts4you.com/download.php?view.3021
https://tuts4you.com/download.php?view.75
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 Dyre - basic patching with OllyDbg 
If your virtual machine has only one CPU configured you can start Process Explorer/Process Monitor and try to 
execute the unpacked Dyre sample. You will observe that the sample quits almost immediately and nothing much 
seems to be happening. The screenshot below shows the Process Tree view as created by Process Monitor tool 
(Tools->Process tree). 
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Now open the unpacked Dyre in OllyDbg. 

 

If you step over (F8) a few times you will notice that at the first jump instruction (JB) the program is jumping to the 
ExitProcess routine. 
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If the value is less than two it terminates the process. 

 

To patch this behaviour click on CMP instruction and press space (or select Assemble from context menu). Replace 
value ‘2’ with ‘1’. 

 

Select modified commands and from the context menu choose Copy to executable -> All modifications and then 
Copy All in the dialog window. 

 

In the new window from the context menu choose Save file and save the patched executable. 
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Now try running the patched executable while observing its behaviour in Process Explorer or Process Monitor 
(process tree). 

 

If everything is done correctly you should see that the Dyre process is creating a new child process which uses 
significantly more time. 
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5. Process creation and injection 

 Following child processes of Tinba loader 

 

5.1.1 First stage 
First open OllyDbg and load the malware sample “doc o likwidacji _ doc_TK2015.exe”. Ignore the error about bad 
format of the executable. 

 

Now you should land in the entry point at 0x401300. 
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Insert breakpoints on the following functions: 

 CreateProcessW 

 SetThreadContext 

 WriteProcessMemory 

 ResumeThread 

Resume the process execution (F9). After a short while you should land at the CreateProcessW breakpoint. As you 
can see either in the stack window or the call stack window (Alt+K) a new process is created in suspended state 
(CREATE_SUSPENDED) and is created using the original executable image. 
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Step over (F8) a few times till you go past return and land back in the loader code. You should land on the 
instruction TEST EAX, EAX. 

 

Scroll down in the assembly code and you should see calls to functions such as GetThreadContext, 
ReadProcessMemory, ZwUnmapViewOfSection, VirtualAllocEx, WriteProcessMemory, SetThreadContext, 
ResumeThread. This is typical for the process hollowing technique. 

Now you could step over the code (F8) and follow how exactly the process hollowing is taking place. 

Resume the execution (F9). The execution should break on WriteProcessMemory. Take a look at the arguments 
passed via stack to the WriteProcessMemory function. 
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You see that the loader overrides 17920 bytes at the address 0x400000 of the previously created child process. If 
you follow in the dump source buffer (0x213000011) you will see typical PE headers with likely some unpacked 
code. 

 

Resume the execution (F9) two times until you break on SetThreadContext function. Write down the address of the 
context structure put on the stack (0x420000 - pContex) and follow it in the dump. 

 

The entry point of the newly created process is stored in its EAX register12. Its value can be read from the context 
structure at the address pContext+0xB013. In this case the entry point address is 0x00401000 (remember about 
little-endian notation). Write down the address of the entry point, it will be needed later. 

                                                           

11 This address might be different. 
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Resume the execution (F9) until you land at the breakpoint on ResumeThread.  

Open Process Hacker and find the suspended child process. Right-click on it and open Properties window. 

 

In the Properties window switch to Memory tab and find a memory block where the entry point is located 
(0x401000 -> memory block 0x400000). Right-click on it and choose Read/Write Memory option. 

                                                                                                                                                                                                

12 EAX value in the context of newly created process, don’t mistake it with the EAX value in OllyDbg which is the value 
of EAX register in the context of currently debugged process. 
13struct CONTEXT http://www.nirsoft.net/kernel_struct/vista/CONTEXT.html  (last accessed 11.09.2015) 

http://www.nirsoft.net/kernel_struct/vista/CONTEXT.html
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In the new window go to the entry point address at offset 0x1000 (addresses are relative to 0x400000). 
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Write down the first two bytes at this offset (0x64A1) and override them with (0xEBFE). Click Write and close the 
window. 

 

 

Now switch back to OllyDbg and step over (F8) till return from ResumeThread function. 

 

Now you can minimize OllyDbg. In the Process Hacker window you can also notice that the child process was 
resumed and is now using a considerable amount of CPU time. This is the result of the endless loop you created in 
this process. Note the process identifier (PID) of the child process (in decimal). 
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Start a new OllyDbg instance and attach it to the child process (File->Attach).  

 

Ignore the error message (the same as previously). You should land somewhere in ntdll. 
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In the assembly window go to the address 0x401000 (EP). You should see the previously injected 0xEBFE bytes. Put 
a breakpoint on this instruction and resume the process (F9). 

 

After you land at the breakpoint select JMP instruction and press Ctrl+E to edit it. Replace EB FE bytes with the 
original 64 A1. 
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After confirmation OllyDbg will automatically reanalyse the code, changing it significantly. 

 

5.1.2 Second stage 
First when still paused at the entry point of the second stage, create a snapshot of the virtual machine (name it 
‘Tinba – second stage’). In case of anything going wrong you wouldn’t need to repeat the entire process. 

Next put breakpoints on the following functions: 

 CreateProcessInternalW 

 GetThreadContext 

 SetThreadContext 

 WriteProcessMemory 

 ResumeThread 

Resume the execution (F9). Shortly you should land at the CreateProcessInternalW call. Right-click on the assembly 
code and select ‘Analyze this!’ (while using the OllyDbg plugin). Next open the Call stack window (View -> Call 
stack, Alt+K). 

 

Continue the execution (F9) till you land at the GetThreadContext breakpoint.  
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Note the address of the pContext structure (in this example it is 0x12FAAC) and follow it at the dump. Next step 
over (F8) till return from GetThreadContext and read EXPLORER.exe entry point from the pContext+0xB0 address. 
Alternatively you can just find explorer.exe executable on the disk and check its entry point address with some PE 
editor (e.g. CFF Explorer). In this situation EP is located at the address 0x4AA8DF. 

 

Resume the execution (F9) till the breakpoint on WriteProcessMemory. 
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Follow the source buffer in the dump address (in this case 0x411026). 

 

Notice names of functions such as MapViewOfFile and OpenFileMapping.  

Select the first two bytes of the source buffer (E8 C2) and press Ctrl+E. Replace them with bytes EB FE. 

 

Next step over WriteProcessMemory function till the user code. You should land at TEST EAX, EAX instruction. 
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Continue the execution (F9) until ResumeThread breakpoint. Now since 0xEBFE trick was already applied you can 
safely step over (F8) the ResumeThread function. 

Minimize OllyDbg window and check in Process Hacker if explorer.exe process was resumed properly. 

 

Next open a new instance of OllyDbg and attach it to the EXPLORER.exe process. 
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After attaching to EXPLORER.exe override EB EF bytes at the entry point as described in the previous section 
(original bytes were E8 C2). If you don’t remember the address of an entry point you can use Debug -> Execute till 
user code (Alt+K) function. 

 

To reach the payload put a breakpoint on OpenFileMappingA and resume the execution (F9). 

After reaching the OpenFileMappingA breakpoint step over (F8) till the user code or choose Debug->Execute till 
user code (Alt+F9). You should land at the PUSH EBX instruction. 
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To reach the final payload step over (F8) the return instruction (RETN).  

 

Now create a snapshot called ‘Tinba’. This snapshot will be used in the later exercises.  
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6. Introduction to scripting 

 Decoding hidden strings in Tinba 
This exercise starts where the previous exercise ended. If necessary, restore the snapshot named Tinba created 
when you reached the main Tinba payload. 

 

Step into (F7), the first call instruction  

 

Next step into the seventh call instruction (F7). 

 

Take a look at the first call instruction. Step into this call (F7). 

You should land at another call instruction followed by a second call to LoadLibraryA. 

 

If you had scrolled up in disassembly window the code would desynchronize. 
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Now follow in dump arg3. 

 

And step over (F8) a call: 

 

Take a look at the memory dump.  

 

To use OllyScript create script.osc file with the following code: 

var base 

var labels 

 

; checking memory base of Tinba payload 

gmemi eip, MEMORYBASE 

mov base, $RESULT 

 

; allocating memory for results 

alloc 1000 

mov labels, $RESULT 

 

; printing header information 

eval "Memory base: 0x{base}" 

log "--------------" 

log "Searching for encoded strings." 

log $RESULT,"" 

log "--------------" 
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search_loop: 

    ; searching for byte pattern 

    find base, #50874424046A??#     

    cmp $RESULT,0 

    je end_loop 

     

    mov base,$RESULT 

    mov push_addr,base+5. 

    mov call_addr,base+7. 

    mov data_addr,base+12. 

     

    ; finding data length 

    gopi push_addr,1,DATA 

    mov len,$RESULT 

     

    ; finding decode routine address 

    gci call_addr,DESTINATION 

    gci $RESULT,DESTINATION 

    mov decode_addr, $RESULT 

     

    ; executing decode routine 

    exec 

        pushad 

        push {labels} 

        push {len} 

        push {data_addr} 

        call {decode_addr} 

        popad 

    ende 

     

    gstr labels 

    mov string, $RESULT 

    fill labels, len, 0 

     

    ; printing result 

    eval "{data_addr} ({len} bytes) -> {string}" 

    log $RESULT,"" 

     

     

    add base,7  

    jmp search_loop 

     

 

end_loop: 

    log "--------------" 

    free labels 

    pause 

To use this script first make sure that the EIP register points to the Tinba payload (for example you haven’t 
followed in any API call). 

Then open ODbgScript Script Window and Log Window. 
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Next load script.osc in Script Window by right-clicking it and choosing Load Script->Open. 

 

When the script is loaded press <space> to resume script execution or right-click on script and from the context 
menu choose Resume. 

 

At the same time take a look at Script Log Window where the decoded strings should be printed. 
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Now that you know all encoded strings you can do typical string analysis to guess some of Tinba’s functionality. For 
example on the strings list you can find strings such as data_before, data_end, data_inject, data_after which tell 
that Tinba is using webinjects technique known from other banking trojans. 

 

Each printed line has the following message format: 

{address} ({data_length}) -> {decoded_string} 

Where {address} is an address where decoding instructions were found. This means that you can use printed 
messages to localize at what part of the code each string was used. 

Additionally you could create a more advanced script, which would not only decode strings but also rewrite the 
Tinba code in such a way that it would reference to already decoded strings instead of decoding them at runtime. 
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