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About ENISA 

The European Union Agency for Network and Information Security (ENISA) is a centre of network and 
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ENISA works with these groups to develop advice and recommendations on good practice in information 
security. It assists EU member states in implementing relevant EU legislation and works to improve the 
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expertise in EU member states by supporting the development of cross-border communities committed to 
improving network and information security throughout the EU. More information about ENISA and its 
work can be found at www.enisa.europa.eu. 
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Main Objective 

The aim of this training is to present methods and techniques of dynamic artefact analysis 

with the use of OllyDbg3 debugger package. 

Trainees will be following a code execution and unpack artefacts using the most efficient 

methods. In addition they will be tracing a malicious code execution. During the process 

trainees will learn how to counter the anti-analysis techniques implemented by malware 

authors.  

In the second part the trainees will study various code injection techniques and how to 

debug hollowed processes. At the end of the training they will be presented how to 

automate the debugging process.  

The training is performed using the Microsoft Windows operating system. 

Targeted Audience 

CSIRT staff involved with the technical analysis of incidents, especially those dealing with the 

sample examination and malware analysis. Prior knowledge of assembly language and 

operating systems internals is highly recommended. 

Total Duration 8-10 hours 

Frequency Once for each team member. 

                                                           

3 OllyDbg http://www.ollydbg.de/ (last accessed 11.09.2015) 

http://www.ollydbg.de/
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1. Training introduction 

In this training you will learn practical elements of advanced dynamic analysis and debugging of malicious code. 
Using a debugger to analyse artefacts helps you to understand how the malicious code operates and gives you more 
details than the behavioural analysis. Moreover, if the original sample is packed then unpack it first with the help of 
a debugger if necessary before proceeding with the static analysis. 

This training begins with the introduction to the OllyDbg debugger (v1.10)4, which will be used throughout later 
exercises. In the second part you will learn about packers and protectors and how to use a debugger to unpack 
binary samples. In the third part you will learn about various anti-debugging and anti-analysis techniques. You will 
also be presented how to perform basic code patching using a sample of Dyre malware5. The fourth part teaches 
various code injection techniques and how to debug hollowed processes. Finally, the training ends with a short 
introduction to debugging automatisation using OllyDbg scripting capabilities. 

Except the introductory part, the samples used in this training are live malware samples. Consequently all analyses 
should be done in dedicated and isolated environments. After each analysis a clean virtual machine snapshot should 
be restored if not instructed otherwise. An Internet connection is not needed to complete this training. 

When debugging malicious code accidental clicks might lead to an uninterrupted code execution and as a result you 
might need to repeat the entire exercise. To prevent this it is advisable to take snapshots of virtual machines after 
analysing major code parts or taking breaks. This way even if something goes ǿǊƻƴƎΣ ȅƻǳ ǿƻƴΩǘ ƴŜŜŘ ǘƻ ǊŜǇŜŀǘ the 
entire process because you will just need to restore the last snapshot. 

                                                           

4 OllyDbg http://www.ollydbg.de/ (last accessed 11.09.2015) 
5 Dyre: Emerging threat on financial fraud landscape 
http://www.symantec.com/content/en/us/enterprise/media/security_response/whitepapers/dyre-emerging-
threat.pdf (last accessed 19.10.2015) 

http://www.ollydbg.de/
http://www.symantec.com/content/en/us/enterprise/media/security_response/whitepapers/dyre-emerging-threat.pdf
http://www.symantec.com/content/en/us/enterprise/media/security_response/whitepapers/dyre-emerging-threat.pdf
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2. Introduction to OllyDbg 

In this part you will be introduced to the OllyDbg6 interface and its basic usage. This will make you ready to complete 
the rest of exercises from the Advanced Dynamic Analysis training. 

You will learn: 

¶ How to use different views in OllyDbg 

¶ How to navigate through the code 

¶ Different methods of tracing executed instructions 

¶ How to create different types of breakpoints 

¶ How to manipulate execution flow of debugged program 

¶ How to use plugins in OllyDbg 

You will use the PuTTY executable7 which is a commonly used Secure Shell (SSH) client. ¢Ƙƛǎ ǿŀȅ ȅƻǳ ŘƻƴΩǘ ƴŜŜŘ ǘƻ 
worry about accidentally execution and if it terminates you can execute it again without problems. 

 OllyDbg interface 
First open OllyDbg debugger. Make sure to run it as Administrator. 

 

If you are using a Windows virtual machine prepared the same way as in the Building artefact handling and 
analysis environment8 training then you can also access OllyDbg using the context menu. 

                                                           

6OllyDbg http://www.ollydbg.de/ (last accessed 11.09.2015) 
7PuTTY: A Free Telnet/SSH Client http://www.chiark.greenend.org.uk/~sgtatham/putty/ (last accessed 11.09.2015) 
8Building artefact handling and analysis environmenthttps://www.enisa.europa.eu/activities/cert/training/training-
resources/technical-operational#building (last accessed 11.09.2015) 

http://www.ollydbg.de/
http://www.chiark.greenend.org.uk/~sgtatham/putty/
https://www.enisa.europa.eu/activities/cert/training/training-resources/technical-operational#building
https://www.enisa.europa.eu/activities/cert/training/training-resources/technical-operational#building
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Now you should see the OllyDbg interface. 

 

There are two ways to start a debugging process. Firstly, you can attach to the already running process. To do this, 
choose File->Attach and then choose the process of your interest. After attaching to the running process, OllyDbg 
should automatically break at the ntdll.DbgBreakPoint function. 
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The second way is to open an executable file using standard File->Open menu. This way OllyDbg will create a new 
child process with a debugged application (debuggee) and stop at the entry point of the executable (by default). 

For example, open the putty.exe binary in OllyDbg. After a while OllyDbg should finish its initial analysis. 
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The Central part of OllyDbg is the CPU window. This is the window you will use most often during an analysis. It 
consists of five separate subpanels: disassembly view, registers, information panel, memory dump and stack panel. 

Disassembly view (4) presents a listing with the disassembled code. It consists of four columns. The leftmost 
column shows the instruction address, the second column contains the hexadecimal representation of the 
instruction (machine code), the third column contains the assembly instruction and finally the fourth column is 
sued to present comments and any additional information. 

 

Registers view (5) presents the current state of CPU registers (for the currently selected thread). 

 

Information panel (6) is used to present additional information about the instruction selected in disassembly view 
(e.g. operation result, registers values). 

 

Memory dump (7) presents a dump of the chosen memory region. 

 

Besides the hexadecimal, you can choose other data representation formats by right-clicking on the memory dump 
panel and choosing required data representation from the context menu. 
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Take some time to check other data representations. At the end, restore the default format: Hex->Hex/ASCII (16 
bytes). 

Finally, stack panel (8) presents the stack state of the currently selected thread. The first column shows the memory 
address while the second column contains the value stored at the given stack address. Notice how the stack grows 
upward in the direction of lower memory addresses. 

 

Besides the CPU window, OllyDbg offers few other windows used for different purposes. All windows can be 
accessed with windows buttons on the toolbar or View menu. 
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The more frequently used windows are: Executable modules, Memory map, Threads, Handles, Call stack, 
Breakpoints. 

The Executable modules window presents all executable modules loaded in the address space of the debugged 
process. Usually, this would be a module of the executed binary and modules of loaded DLL libraries. You can double-
click on any of the modules to immediately jump to this module in the disassembly view. You can also right-click on 
any of the modules to access context menu with additional operations. 

 

For example, right-click on msvcrt and choose View names to be presented with a list of all names defined in the 
msvcrt library (imports and exports). 
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Memory map window presents the memory structure with all allocated memory regions in the address space of the 
debugged process. It is useful to track memory allocation operations done by the malicious code. Similarly as in the 
previous example you can right-click on any memory region to access the context menu with additional operations 
(dumping memory, searching memory, changing access rights, freeing memory, etc.). 

 

For example sometimes it is useful to open an additional dump window with a dump of the given memory region. 
To do this double-click on the memory region or select it and choose Dump option from the context menu. 

 

Another operation you might try is searching all memory regions for a particular string or byte pattern. LetΩǎ say you 
know that somewhere in the memory the string Ψwrong passphraseΩ is present, ōǳǘ ȅƻǳ ŘƻƴΩǘ ƪƴƻǿ the exact address 
nor in which memory region is it located. 

To solve this problem, right-click anywhere in the memory map and choose Search (Ctrl+B) from the context menu. 
In the new window, type ΨǿǊƻƴƎ ǇŀǎǎǇƘǊŀǎŜΩ and click Ok. 
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If the string is found OllyDbg will open a new Dump window with the position set on the string. 

 

Here you see that the string was found at the virtual address 0x4676BC which belongs to memory region 0x45D000-
0x479FFF (putty:.rdata). 

To keep searching for other occurrences of this string in this memory region click on Dump window (to make it active) 
and keep pressing Ctrl+L. When there is no more occurrences, OllyDbg will signal this with the ΨLǘŜƳ ƴƻǘ ŦƻǳƴŘΩ 
message at the bottom of the window. 

 

To continue searching for the string in other memory regions go back to Memory map window (make it active) and 
keep pressing Ctrl+L. If there is no more occurrences, OllyDbg will signal this with the same message at the bottom 
of the window. 

Threads window shows all threads of the current process. If the process has more than one thread, double-clicking 
on the thread would switch the context to this thread. 
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Handles window shows all windows opened by the process handles with an additional information regarding the 
handle type, value and name. This window may be useful if for example you see that some API call is referring to a 
ŎŜǊǘŀƛƴ ƘŀƴŘƭŜ ŀƴŘ ȅƻǳ ŘƻƴΩǘ ǊŜƳŜƳōŜǊ ǿƘŀǘ ǘƘƛǎ ƘŀƴŘƭŜ ƛǎΦ 

 

Finally call stack window shows all function calls made up to the current instruction in the current thread. This is 
useful for checking to which function the current instruction belongs to and from where this function was called. 
Note that the screenshot below presents the Call stack window during process execution, after two calls were made. 
If you open the Call stack window while at the entry point, it will be empty. 

 

One of the useful OllyDbg features is highlighting elements that have changed. A good example of this is highlighting 
newly allocated memory blocks or newly loaded modules. 

To present this, open the Executable modules window. If there are any red coloured elements in the window, right-
click it and choose Actualize. 
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Next, right-click anywhere in the window and choose Insert module from the context menu (this operation is 
available only with Olly Advanced plugin). 

 

In the Open dialog, choose c:\Windows\System32\wininet.dll. This way OllyDbg will load an additional module in the 
address space of the currently debugged process. Loading extra modules is sometimes useful in more advanced 
debugging when you want to load the DLLs with your custom code. 

Now all the newly loaded modules should be marked with red font in the Executable modules window. Notice that 
besides the wininet module, a couple other DLLs were loaded. Those are the DLLs that were required by wininet. 

 

The same rule of red-colouring new elements applies also to Memory map and various other views in OllyDbg. In 
general this is useful in tracking places in the code where new modules are loaded or new memory is allocated. 

 Basic debugging and code navigation 
Start by loading the putty.exe sample as described in the previous exercise. 

Each debugged process can be in one of the following states: paused, running, terminated, tracing and animating. 

¶ Paused ς program execution is paused, no instructions are being executed 

¶ Running ς program is freely running and debugger is not tracing its execution 

¶ Terminated ς debugged process has terminated 

¶ Tracing ς when instruction tracing was started (each executed instruction is logged) 

¶ Animating ς when instruction animation was started. 

The current state of the debugged process can be read in the upper left corner of the OllyDbg window. 

 

When the process is paused, the current position (the instruction pointer) is indicated by a black square in the 
disassembly view and by the value of EIP register. 
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Whenever you get lost, double-click on the EIP register value to be instantaneously moved to the current position in 
the code. Remember that if the program has multiple threads, the current position will likely be different for each 
thread. 

 

When debugging a program you will spend most of the time on analysing disassembled instructions step-by-step. 
There are two modes of instruction stepping: 

¶ Step into (F7) ς executes current instruction and moves program execution to the next instruction. If the 
current instruction is a function call then the debugger steps into the call and starts stepping over 
instructions of the called function. 

¶ Step over (F8) ς behaves the same as Step into except if the current instruction is a function call, the 
ŘŜōǳƎƎŜǊ ŘƻŜǎƴΩǘ ǎǘŜǇ ƛƴǘƻ ǘƘƛǎ ŎŀƭƭΦ 

If you want to let the program run freely choose Run (F9). In the result, PuTTY will create its main window and 
present it to the user. If you want to pause the program execution then press F12 (Debug->Pause) while staying in 
OllyDbg. You can also restart the executable by pressing Ctrl+F2 (Debug->Restart). 

Other useful debug operations are: 

¶ Run to selection (F4) ς causes OllyDbg to resume execution until the selected instruction 

¶ Execute till return (Ctrl+F9) ς executes the program until return from current function 

¶ Execute till user code (Alt+F9) ς executes program until user code 

Debugging actions can be also accessed through the toolbar at the top of OllyDbg. 
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If you want to quickly pre-view the execution flow of a program (find loops, check which jumps are taken, etc.) you 
might decide to use the instruction trace or instruction animation functions. Both functions come in two forms: Trace 
into/Trace over and Animate into/Animate over. 

 

To see how the instruction animation works, restart PuTTY sample (Debug->Reset) and then choose Debug -> 
Animate over (Ctrl+F8). Observe what happens in the disassembly window. 

You should see a short animation of executed instructions and after a few moments PuTTYΩǎ main window should 
appear. 

Close PuTTY and reset the sample. Now choose Debug->Animate into. This time instead of stepping over, the 
animation will step into each function call (including API calls). You can open the Call stack (Alt+K) window to observe 
all called functions in the real time. 

 

Animate into function usually takes some time until the program finishes execution. To stop it, use Pause (F12) 
function. 
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Next restart the sample again and choose Debug->Set condition. 

 

In this dialog you can set conditions on how long the Run trace function should be running (conditions set here would 
also work for animate function). If you set more than one condition, run trace will be running until one of those 
conditions is met. It is important to note that if the condition is met inside the body of some called function and you 
are using Trace over function, it will not work. 

For example set the following two conditions. 

 

 

This would make instruction tracing stop either when the execution moves outside of the memory range 0x400000-
0x500000, or when the current command would be call eax or call edi. 

Now open Run trace window (View->Run trace) and then choose Debug->Trace over. Execution should soon stop 
at the call edi instruction. 

 

This would also be indicated at the OllyDbg status bar in the bottom left corner. 
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Notice that execution hasƴΩǘ ǎǘƻǇped on the condition of EIP register being outside of the given memory range even 
though there were some API calls already made in the code. This is because you used the Trace over function and 
the API calls were stepped over. If you had used the Trace into function, execution would stop at the first API call. 

Now take a look at the Run trace window. It contains all executed instructions with information about the instruction 
address, thread and modified registers. The last executed instruction is at the bottom of the window. 

 

If you would like run trace to be logged to a file you should right-click on Run trace window and choose the Log to 
file option from the context menu (before executing Run trace function). 

At this point you should know the basic debugging operations and functions. The next important thing to learn is 
how to navigate through the code. 

First restart the PuTTY sample. 

 

Whenever you see some call or jump instruction you can follow it (without executing) by clicking on this 
instruction and pressing <Enter>. 

In this example follow a call to putty.004545A0. You should land at the function body. 

 

You can do the same with jump instructions. 

One of the drawbacks of following calls and jumps in OllyDbg is the lack of a άGo backέ ŦǳƴŎǘƛƻƴΦ ¢Ƙŀǘ ƛǎ, if you follow 
some jumps and calls, there is no easy way of going back to the previous position in a way that IDA Pro /  IDA Free9 
allows. You just need to remember what code you have followed or use the Bookmarks plugin (you will learn more 
about plugins in a later part of the exercise). 

                                                           

9 Freeware version of IDA v5.0 https://www.hex-rays.com/products/ida/support/download_freeware.shtml (last 
accessed 11.09.2015) 

https://www.hex-rays.com/products/ida/support/download_freeware.shtml
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Another way of navigating through the code is using the Go to expression feature. It can be used to change the 
current position in disassembly view, memory dump or stack view ς depending on which view is active. 

Click on disassembly view and press Ctrl+G. 

 

Type eip to be moved to the current location in the code (pointed by EIP register). 

In Enter expression to follow dialog you can enter a wide range of expressions: 

¶ registers: eax, ebx, ecx 

¶ memory addresses: 0x401000 

¶ arithmetic expressions: 0x400000+2*0x1002, eax+0x1000 

¶ API functions names: CreateFileA, WriteProcessMemory 

¶ Labels or other names used in program. 

If the entered expression is invalid or the destination address ŘƻŜǎƴΩǘ ŜȄƛǎǘ ƛƴ the address space of the debugged 
process you will see a proper error message. 

 

Additionally, if you want to find the address of a certain API function, but the module in which this function is located 
hasƴΩǘ ōŜŜƴ loaded yet (it is being loaded at runtime as it is going to be called) you will also see an error message 
(Unknown identifier). 

Another often used way of code navigation in OllyDbg is through context menus. You can click on various values in 
OllyDbg (register values, immediate values, stack stored values, strings) and in the context menu there will often be 
options like: 

¶ Follow in Disassembler 

¶ Follow in Dump 

¶ Follow in Stack 

For example, start clicking on registers values. If a register points to the existing address in the address space of the 
current program, there should be the following options: Follow in Disassembler and Follow in Dump. 
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If the register does not contain a valid address, these ƻǇǘƛƻƴǎ ǿƻƴΩǘ ōŜ ŀǾŀƛƭŀōƭŜΦ !ŘŘƛǘƛƻƴŀƭƭȅ ƛŦ a register points to 
the location on the stack (like in case of ESP register) there will be an option Follow in Stack. 

You can do the same with values stored on stack. 
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 Breakpoints 
Breakpoints are crucial parts of any debugger. They allow to stop the program execution at a chosen moment 
allowing the user to analyse specific program functions. 

There are four types of breakpoints in OllyDbg10: 

¶ Software breakpoints (INT 3 breakpoints) 

¶ Hardware breakpoints 

¶ Memory breakpoints 

¶ Guarded pages 

Software breakpoints work by inserting an INT 311 instruction in the place of the Instruction on which the breakpoint 
is set. When the instruction is about to be executed, the interrupt is raised and the debugger steps in. The entire 
process is transparent to the user. 

Setting software breakpoints actually modifies memory of debugged process. Thus when the debugged process was 
about to calculate the checksum of its own code, it might be different than expected. Some malicious code uses this 
as one of the anti-debugging techniques to detect if they are being debugged. 

To set a software breakpoint, double-click in the second column next to the instruction or select an instruction and 
press F2. When the breakpoint is set this will be indicated by a red background of the instruction address. 

 

Now press F9 (run) and the program should stop execution on this instruction (before executing it). 

 

To remove a breakpoint, repeat the same steps as when setting it. 

You can view a list of all software breakpoints in the Breakpoints window. 

                                                           

10 http://www.ollydbg.de/Help/i_Breakpoints.htm (last accessed 11.09.2015) 
11 The INT 3 instruction is defined for use by debuggers to temporarily replace an instruction in a running program in 
order to set a breakpoint. https://en.wikipedia.org/wiki/INT_(x86_instruction)  (last accessed 11.09.2015) 

http://www.ollydbg.de/Help/i_Breakpoints.htm
https://en.wikipedia.org/wiki/INT_(x86_instruction)
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You can also use this window to remove or temporarily disable chosen breakpoints. 

One way of using breakpoints is to set them on API functions. This allows to detect when a certain API function is 
called by malicious code and can be used to detect various operations done by malware. For example if you are 
interested in communication with C&C servers it is a good idea to set breakpoints on network related functions. And 
if you suspect that the process is injecting some code to other processes, you might set breakpoints on functions 
such as WriteProcessMemory or CreateRemoteThread. 

Now you will set a breakpoint on ShellExecuteA function. 

First click on disassembly view and use Go to expression (Ctrl+G) to find the address of ShellExecuteA. 

 

Then set breakpoint on the first instruction of ShellExecuteA (the one to which you were moved). 

 

If the PuTTY process was paused, resume execution (F9). 

Next in the PuTTY window, click the About button and then the Visit Web Site button. 
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Now go back to OllyDbg. OllyDbg should break on a call to ShellExecuteA (on the previously set breakpoint). 

 

 

Take a look at the stack view to see arguments passed to ShellExecuteA. 

 

As you can see, after clicking Visit Web Site, PuTTY tries to open the http address 
http://www.chiark.greenend.org.uk/~sgtatham/putty/ in the default system web browser. 

You can also open the call stack window (View->Call stack, Clt+K) to check from where ShellExecuteA function was 
called. 

http://www.chiark.greenend.org.uk/~sgtatham/putty/
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The second type of breakpoints are hardware breakpoints. In general, instead of changing program instructions in 
the memory as software breakpoints do, they use special processor registers (debug registers). On the x86 
architecture there are four debug registers (DR0-DR3) used to store the linear address of breakpoints. Thus it is 
possible to set four hardware breakpoints at a time. Additionally, in contrast to software breakpoints, hardware 
breakpoints can be also used to break on memory read or write operations. 

Hardware breakpoints are usually used when you want to detect when a certain memory address is being written 
to or when you know that the malicious code is trying to detect software breakpoints. 

To get more information on differences between software and hardware breakpoints refer to the Debugger flow 
control 1213 articles by Ken Johnson. 

bƻǿ ƭŜǘΩǎ see how to set up hardware breakpoints: go to OllyDbg and restart the PuTTY sample. 

 

Next, step over until the instruction at 0x454AF9. As you can see some dword value is being written to the memory 
at the address 0x47E140. 

 

[ŜǘΩǎ ǎŀȅ you want to check at what place in the code this value will be used again. 

Right-click on this instruction and from the context menu choose Follow in Dump->Memory address. 

                                                           

12Debugger flow control: Hardware breakpoints vs software breakpoints http://www.nynaeve.net/?p=80 (last 
accessed 11.09.2015) 
13Debugger flow control: More on breakpoints (part 2) http://www.nynaeve.net/?p=81  (last accessed 11.09.2015) 

http://www.nynaeve.net/?p=80
http://www.nynaeve.net/?p=81
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Now Memory Dump view should be centred on the 0x47E140 address. Select the first 4 bytes (dword) and right-click 
on them. From the context menu choose Breakpoint->Hardware, on access->Dword. 

 

Now if at any place of the code this memory address would be accessed, the hardware breakpoint will hit and the 
program execution will be paused. 

To view all currently set hardware breakpoints, choose Debug->Hardware breakpoints. 

 

You can use this window to follow the memory address where the hardware breakpoint is set, or to delete the 
breakpoint. 

After setting up a hardware breakpoint on 0x47E140, resume the program execution (F9). 
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Almost immediately the program should break. As the message in the status bar shows, hardware breakpoint 1 was 
hit and EIP points to one instruction after 0x47E140 address was accessed. 

 

Scroll the disassembly view one line up to see the instruction accessing 0x47E140. 

 

You can now remove the hardware breakpoint (it is not automatically removed after the sample reload). 

Hardware breakpoints can be used instead of software breakpoints, for instruction stepping or tracing. To configure 
this go to Options-Debugging options->Debug ŀƴŘ ǎŜƭŜŎǘ άUse hardware breakpoints to step or trace codeέΦ 5ƻƴΩǘ 
select this option right now however, since in the remaining part of this training software breakpoints are used! 

 

The third type of breakpoints are memory breakpoints. They can be used to detect memory read or write operations. 
They are set for memory pages and it is not possible to set them only for a byte, word or dword memory range. This 
makes them less accurate than hardware breakpoints but in contrast to hardware breakpoints, the number of 
memory breakpoints is not limited. 

Typical usage for memory breakpoints is the detection of read or write operations on large memory blocks (for 
example newly allocated memory). 

You can set memory breakpoints in a similar manner as hardware breakpoints by selecting some data in Memory 
Dump view and then choosing Breakpoint->Memory. 










































































































































